It is normal to see the following dialog when first launching Ecamm Live on a new Mac:

While Ecamm Live is M1 native, some sub-processes still need Rosetta for Ecamm Live to run. The Ecamm Live application itself, however, is running M1 native and will take advantage of the processing enhancements offered by the M1 platform.

Did this answer your question?