All Collections
Getting Started with Ecamm Live
Using Ecamm Live with Other Apps
Importing Ecamm Live Marker file into Adobe Premiere Pro
Importing Ecamm Live Marker file into Adobe Premiere Pro

There are a few quick steps to bring markers created using Ecamm into your Adobe Premiere Pro timeline.

Glen Aspeslagh avatar
Written by Glen Aspeslagh
Updated over a week ago

Ecamm Live's marker feature creates a text file containing time stamps and marker text. Although Adobe Premiere's marker import feature is very limited, it's possible to import Ecamm's markers using a free extension.

(Don't worry, you'll only have to follow the first four steps once!)

  1. Download the free MarkerBox extension.

  2. Install using the steps on the MarkerBox website.

  3. For newer versions of Premiere, when following the steps in the Trusting the Extension section, also run this Terminal command:

    defaults write com.adobe.CSXS.11 PlayerDebugMode 1

  4. Quit and re-open Adobe Premiere Pro. You should now see a new MarkerBox extension listed in Extensions sub-menu in the Window menu at the top of the screen. Pick it to open MarkerBox.


  5. Now open your Ecamm Live marker file in Microsoft Excel or Apple's Numbers. Choose to use Fixed Width delimiters, so that the timestamps and marker titles are each in their own column. Number's Import setting should look like this, with one green delimiter directly after the times:


  6. In Numbers or Excel, select the spreadsheet's contents, and pick Copy from the Edit menu.

  7. In the MarkerBox window, use Paste from the Edit menu to paste the markers, and then click the Import from text area button.

Did this answer your question?