The current version of Call Recorder requires macOS 10.12 or newer. Customers also have access to some older versions of Call Recorder to accommodate older macOS versions:

macOS 10.10 and 10.11 users should use Call Recorder v2.9.1 and the latest Skype. 

Links to this download will be presented automatically on the Customer Center download page when accessed from an older macOS version.

Did this answer your question?